Information Exposure Affecting microsoft.netcore package, versions [5.0.0,5.0.9) [3.1.0,3.1.18) [2.1.0,2.1.29)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTNETCORE-1540874

  • published

    13 Aug 2021

  • disclosed

    13 Aug 2021

  • credit

    Unknown

How to fix?

Upgrade Microsoft.NETCore to version 5.0.9, 3.1.18, 2.1.29 or higher.

Overview

Microsoft.NETCore is a package that provides a set of packages that can be used when building portable libraries on .NETCore based platforms.

Affected versions of this package are vulnerable to Information Exposure via an unknown attack vector.