Remote Code Execution (RCE) Affecting microsoft.netcore.app package, versions [3.0.1, 3.0.2) [3.1.0, 3.1.1)


0.0
high
  • Attack Complexity

    High

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTNETCOREAPP-541848

  • published

    15 Jan 2020

  • disclosed

    14 Jan 2020

  • credit

    Soroush Dalili

How to fix?

Upgrade Microsoft.NETCore.App to version 3.0.2, 3.1.1 or higher.

Overview

Microsoft.NETCore.App is a set of .NET API's that are included in the default .NET Core application model.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) when the software fails to check the source markup of a file. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user.