Improper Input Validation Affecting microsoft.powerbi.javascript package, versions [0,]


Severity

0.0
medium
0
10

    Threat Intelligence

    EPSS
    0.12% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-MICROSOFTPOWERBIJAVASCRIPT-6848694
  • published 15 May 2024
  • disclosed 14 May 2024
  • credit Marcelo Takizawa

How to fix?

Upgrade Microsoft.PowerBI.JavaScript to version or higher.

Overview

Microsoft.PowerBI.JavaScript is a suite of JavaScript web components for integrating Power BI into your app.

Affected versions of this package are vulnerable to Improper Input Validation via the client-side data handling process. An attacker can expose sensitive information by intercepting improperly secured data transmissions.

References

CVSS Scores

version 3.1
Expand this section

Snyk

6.5 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    Required
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    None
  • Availability (A)
    None
Expand this section

NVD

6.5 medium