SQL Injection Affecting npgsql package, versions [,2.2.6)


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-NPGSQL-469157
  • published 26 Sep 2019
  • disclosed 25 Aug 2015
  • credit Maciej Aniserowicz

How to fix?

Upgrade Npgsql to version 2.2.6 or higher.

Overview

Npgsql is a .NET data provider for PostgreSQL.

Affected versions of this package are vulnerable to SQL Injection. None