Information Exposure Affecting nuget.commandline Open this link in a new tab package, versions [3.5.0,4.9.5) [5.0.0,5.2.1) [5.3.0,5.7.2) [5.8.0,5.9.2) [5.10.0,5.11.2) [6.0.0,6.0.2) [6.1.0,6.2.1)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-NUGETCOMMANDLINE-2871345

  • published

    15 Jun 2022

  • disclosed

    14 Jun 2022

  • credit

    Unknown

How to fix?

Upgrade NuGet.CommandLine to version 4.9.5, 5.2.1, 5.7.2, 5.9.2, 5.11.2, 6.0.2, 6.2.1 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure due to an incorrect comparison with a server URL. This can cause a nuget.org API key leakage.

References