Uncontrolled Resource Consumption Affecting opcfoundation.netstandard.opc.ua package, versions [,1.4.368.58)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.2% (58th percentile)
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-OPCFOUNDATIONNETSTANDARDOPCUA-2932025
  • published 19 Jun 2022
  • disclosed 17 Jun 2022
  • credit Uriya Yavnieli

How to fix?

Upgrade OPCFoundation.NetStandard.Opc.Ua to version 1.4.368.58 or higher.

Overview

OPCFoundation.NetStandard.Opc.Ua is a package that contains the OPC UA reference implementation and is targeting the .NET Standard Library.

Affected versions of this package are vulnerable to Uncontrolled Resource Consumption. This vulnerability allows a malicious client to trigger a stack overflow exception in a server that exposes an HTTPS endpoint.