Insufficient Validation Affecting opcfoundation.netstandard.opc.ua Open this link in a new tab package, versions [,1.4.359.31)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-OPCFOUNDATIONNETSTANDARDOPCUA-560386

  • published

    16 Mar 2020

  • disclosed

    16 Mar 2020

  • credit

    Bernd Edlinger

How to fix?

Upgrade OPCFoundation.NetStandard.Opc.Ua to version 1.4.359.31 or higher.

Overview

OPCFoundation.NetStandard.Opc.Ua is a package that contains the OPC UA reference implementation and is targeting the .NET Standard Library.

Affected versions of this package are vulnerable to Insufficient Validation. Encrypted user credentials sent to a misbehaving Server can be intercepted and reused by an attacker.