Improper Authorization Affecting orchardcore package, versions [,1.3.0)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.05% (19th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-ORCHARDCORE-2421202
  • published 11 Mar 2022
  • disclosed 11 Mar 2022
  • credit Rohan Sharma

How to fix?

Upgrade OrchardCore to version 1.3.0 or higher.

Overview

OrchardCore is an application framework for building modular, multi-tenant applications on ASP.NET Core.

Affected versions of this package are vulnerable to Improper Authorization which allows a low-privilege user to create a number of roles that breaks the authorization principle of this application.