Cross-site Request Forgery (CSRF) Affecting piranha.manager package, versions [4.0.0-alpha1, 10.0.0)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-PIRANHAMANAGER-1921109

  • published

    16 Nov 2021

  • disclosed

    16 Nov 2021

  • credit

    Unknown

How to fix?

Upgrade Piranha.Manager to version 10.0.0 or higher.

Overview

Piranha.Manager is a manager panel for Piranha CMS for AspNetCore.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) through various actions supported by the management system, such as deleting a user, deleting a role, editing a post, deleting a media folder, etc., when an ID is known.