Credential Exposure Affecting system.directoryservices.protocols package, versions [,5.0.1)


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-SYSTEMDIRECTORYSERVICESPROTOCOLS-1730569

  • published

    13 Oct 2021

  • disclosed

    12 Oct 2021

  • credit

    Unknown

How to fix?

Upgrade System.DirectoryServices.Protocols to version 5.0.1 or higher.

Overview

System.DirectoryServices.Protocols is a package that provides the methods defined in the Lightweight Directory Access Protocol (LDAP) version 3 (V3) and Directory Services Markup Language (DSML) version 2.0 (V2) standards.

Affected versions of this package are vulnerable to Credential Exposure. System.DirectoryServices.Protocols.LdapConnection may send credentials in plain text on Linux.

References