Improper Input Validation Affecting system.management.automation Open this link in a new tab package, versions [6.2.0,6.2.3) [,6.1.6)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-SYSTEMMANAGEMENTAUTOMATION-536079

  • published

    26 Nov 2019

  • disclosed

    11 Sep 2019

  • credit

    Unknown

How to fix?

Upgrade System.Management.Automation to version 6.2.3, 6.1.6 or higher.

Overview

System.Management.Automation is a System Management Automation for PowerShell.

Affected versions of this package are vulnerable to Improper Input Validation. PowerShell Core or .NET Core improperly handles web requests. An attacker who successfully exploited this vulnerability could cause a denial of service against a PowerShell Core script.