Privilege Escalation Affecting system.net.http package, versions [,4.1.2) [4.3,4.3.2)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-SYSTEMNETHTTP-60047

  • published

    12 May 2017

  • disclosed

    12 May 2017

  • credit

    Unknown

How to fix?

Upgrade System.Net.Http to version 4.1.2, 4.3.2 or higher.

Overview

System.Net.Http Provides a programming interface for modern HTTP applications, including HTTP client components that allow applications to consume web services over HTTP and HTTP components that can be used by both clients and servers for parsing HTTP headers.

Affected versions of this package are vulnerable to Privilege Escalation due to failing to properly sanitize web requests.

References