Cross-site Request Forgery (CSRF) Affecting umbracocms package, versions [,8.5.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.2% (57th percentile)
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-UMBRACOCMS-5775818
  • published 14 Jul 2023
  • disclosed 24 May 2022
  • credit Anastasia Melnikova

How to fix?

Upgrade UmbracoCms to version 8.5.1 or higher.

Overview

UmbracoCms is a package that installs Umbraco Cms in your Visual Studio ASP.NET project

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) which allows an attacker to perform arbitrary web requests with the identity of the victim, e.g. in order to enable/disable or delete user accounts.