Information Exposure Affecting umbracocms.core package, versions [13.0.0,13.1.1)


Severity

0.0
medium
0
10

    Threat Intelligence

    EPSS
    0.04% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-UMBRACOCMSCORE-6617048
  • published 17 Apr 2024
  • disclosed 17 Apr 2024
  • credit Unknown

How to fix?

Upgrade UmbracoCms.Core to version 13.1.1 or higher.

Overview

UmbracoCms.Core is an ASP.NET CMS.

Affected versions of this package are vulnerable to Information Exposure due to the logging of failing webhooks when the solution is not in debug mode. An attacker can obtain critical information that should not be accessible externally by exploiting the logs generated from these failing webhooks.

Workaround

Disabling webhooks functionality.

References

CVSS Scores

version 3.1
Expand this section

Snyk

4.1 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    High
  • User Interaction (UI)
    None
  • Scope (S)
    Changed
  • Confidentiality (C)
    Low
  • Integrity (I)
    None
  • Availability (A)
    None