Incorrect Permission Assignment for Critical Resource Affecting accountsservice package, versions <22.08.8-4


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-ACCOUNTSSERVICE-18306852
  • published25 Jul 2026
  • disclosed27 Nov 2019

Introduced: 27 Nov 2019

CVE-2012-6655  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Echo:latest accountsservice to version 22.08.8-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream accountsservice package and not the accountsservice package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue exists AccountService 0.6.37 in the user_change_password_authorized_cb() function in user.c which could let a local users obtain encrypted passwords.

CVSS Base Scores

version 3.1