Out-of-bounds Write Affecting boost-1.69.0 package, versions <1.69.0+e1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
19.24% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-BOOST1690-21280011
  • published20 Oct 2026
  • disclosed5 Aug 2022

Introduced: 5 Aug 2022

CVE-2022-37434  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Echo:latest boost-1.69.0 to version 1.69.0+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream boost-1.69.0 package and not the boost-1.69.0 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

References

CVSS Base Scores

version 3.1