Improper Input Validation Affecting bubblewrap package, versions <0.1.5-2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.2% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-BUBBLEWRAP-19339063
  • published27 Aug 2026
  • disclosed29 Mar 2017

Introduced: 29 Mar 2017

CVE-2017-5226  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest bubblewrap to version 0.1.5-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

When executing a program via the bubblewrap sandbox, the nonpriv session can escape to the parent session by using the TIOCSTI ioctl to push characters into the terminal's input buffer, allowing an attacker to escape the sandbox.