Improper Input Validation Affecting bubblewrap package, versions <0.3.1-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.58% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-BUBBLEWRAP-19339066
  • published27 Aug 2026
  • disclosed29 May 2019

Introduced: 29 May 2019

CVE-2019-12439  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest bubblewrap to version 0.3.1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

bubblewrap.c in Bubblewrap before 0.3.3 misuses temporary directories in /tmp as a mount point. In some particular configurations (related to XDG_RUNTIME_DIR), a local attacker may abuse this flaw to prevent other users from executing bubblewrap or potentially execute code.