Out-of-bounds Read Affecting cimg package, versions <2.3.6+dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.21% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-CIMG-18291404
  • published24 Jul 2026
  • disclosed2 Mar 2018

Introduced: 2 Mar 2018

CVE-2018-7640  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Echo:latest cimg to version 2.3.6+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in CImg v.220. A heap-based buffer over-read in load_bmp in CImg.h occurs when loading a crafted bmp image, a different vulnerability than CVE-2018-7588. This is in a Monochrome case, aka case 1.