Improper Input Validation Affecting condor package, versions <8.2.3~dfsg.1-6


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.11% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-CONDOR-21184592
  • published18 Oct 2026
  • disclosed31 Jan 2020

Introduced: 31 Jan 2020

CVE-2014-8126  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest condor to version 8.2.3~dfsg.1-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream condor package and not the condor package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The scheduler in HTCondor before 8.2.6 allows remote authenticated users to execute arbitrary code.

CVSS Base Scores

version 3.1