CVE-2004-1013 Affecting cyrus-imapd package, versions <1.5.19-20


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.83% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-CYRUSIMAPD-18000839
  • published17 Jul 2026
  • disclosed10 Jan 2005

Introduced: 10 Jan 2005

CVE-2004-1013  (opens in a new tab)

How to fix?

Upgrade Echo:latest cyrus-imapd to version 1.5.19-20 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cyrus-imapd package and not the cyrus-imapd package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The argument parser of the FETCH command in Cyrus IMAP Server 2.2.x through 2.2.8 allows remote authenticated users to execute arbitrary code via certain commands such as (1) "body[p", (2) "binary[p", or (3) "binary[p") that cause an index increment error that leads to an out-of-bounds memory corruption.

CVSS Base Scores

version 3.1