CVE-2006-2878 Affecting dokuwiki package, versions <0.0.20060309-4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
13.93% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-DOKUWIKI-21691981
  • published24 Oct 2026
  • disclosed7 Jun 2006

Introduced: 7 Jun 2006

CVE-2006-2878  (opens in a new tab)

How to fix?

Upgrade Echo:latest dokuwiki to version 0.0.20060309-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dokuwiki package and not the dokuwiki package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The spellchecker (spellcheck.php) in DokuWiki 2006/06/04 and earlier allows remote attackers to insert and execute arbitrary PHP code via "complex curly syntax" that is inserted into a regular expression that is processed by preg_replace with the /e (executable) modifier.

CVSS Base Scores

version 3.1