Access Restriction Bypass Affecting dokuwiki package, versions <0.0.20090214b-3.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
10.75% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-DOKUWIKI-21691992
  • published24 Oct 2026
  • disclosed15 Feb 2010

Introduced: 15 Feb 2010

CVE-2010-0288  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Echo:latest dokuwiki to version 0.0.20090214b-3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dokuwiki package and not the dokuwiki package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A typo in the administrator permission check in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25b allows remote attackers to gain privileges and access closed wikis by editing current ACL statements, as demonstrated in the wild in January 2010.

CVSS Base Scores

version 3.1