CVE-2024-30105 Affecting dotnet-sdk-7.0 package, versions <7.0.410+e1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.94% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-DOTNETSDK70-21817090
  • published29 Oct 2026
  • disclosed9 Jul 2024

Introduced: 9 Jul 2024

CVE-2024-30105  (opens in a new tab)

How to fix?

Upgrade Echo:latest dotnet-sdk-7.0 to version 7.0.410+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dotnet-sdk-7.0 package and not the dotnet-sdk-7.0 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

.NET and Visual Studio Denial of Service Vulnerability

CVSS Base Scores

version 3.1