Improper Input Validation Affecting ejabberd package, versions <2.1.2-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.11% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-EJABBERD-20414107
  • published3 Oct 2026
  • disclosed3 Feb 2010

Introduced: 3 Feb 2010

CVE-2010-0305  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Echo:latest ejabberd to version 2.1.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ejabberd package and not the ejabberd package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

ejabberd_c2s.erl in ejabberd before 2.1.3 allows remote attackers to cause a denial of service (daemon crash) via a large number of c2s (aka client2server) messages that trigger a queue overload.

CVSS Base Scores

version 3.1