Resource Management Errors Affecting ejabberd package, versions <2.1.9-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.05% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-EJABBERD-20414109
  • published3 Oct 2026
  • disclosed18 Feb 2012

Introduced: 18 Feb 2012

CVE-2011-4320  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Echo:latest ejabberd to version 2.1.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ejabberd package and not the ejabberd package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The mod_pubsub module (mod_pubsub.erl) in ejabberd 2.1.8 and 3.0.0-alpha-3 allows remote authenticated users to cause a denial of service (infinite loop) via a stanza with a publish tag that lacks a node attribute.

CVSS Base Scores

version 3.1