Buffer Overflow Affecting fastnetmon package, versions <1.2.9-0+deb13u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.12% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-FASTNETMON-17978357
  • published15 Jul 2026
  • disclosed26 May 2026

Introduced: 26 May 2026

CVE-2026-48696  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Echo:latest fastnetmon to version 1.2.9-0+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fastnetmon package and not the fastnetmon package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

FastNetMon Community Edition through 1.2.9 has a buffer overflow, a different vulnerability than CVE-2026-48686 and CVE-2026-48689.

CVSS Base Scores

version 3.1