Stack-based Buffer Overflow Affecting fltk1.3 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.16% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-FLTK13-21884710
  • published30 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-116723  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

There is no fixed version for Echo:latest fltk1.3.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fltk1.3 package and not the fltk1.3 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

FLTK through 1.4.5 contains a stack-based buffer overflow vulnerability in Fl_BMP_Image::load_bmp_() that allows attackers to corrupt stack memory by supplying an oversized BMP colors_used field. Attackers can craft BMP or ICO files with colors_used above 256 to overflow the 768-byte colormap array, causing crashes or potential code execution.

CVSS Base Scores

version 3.1