Resource Management Errors Affecting gnome-shell package, versions <3.14.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.47% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-GNOMESHELL-19865208
  • published16 Sept 2026
  • disclosed25 Dec 2014

Introduced: 25 Dec 2014

CVE-2014-7300  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Echo:latest gnome-shell to version 3.14.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-shell package and not the gnome-shell package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

GNOME Shell 3.14.x before 3.14.1, when the Screen Lock feature is used, does not limit the aggregate memory consumption of all active PrtSc requests, which allows physically proximate attackers to execute arbitrary commands on an unattended workstation by making many PrtSc requests and leveraging a temporary lock outage, and the resulting temporary shell availability, caused by the Linux kernel OOM killer.

CVSS Base Scores

version 3.1