Improper Locking Affecting gssproxy package, versions <0.8.4-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.77% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-GSSPROXY-21751196
  • published27 Oct 2026
  • disclosed31 Dec 2020

Introduced: 31 Dec 2020

CVE-2020-12658  (opens in a new tab)
CWE-667  (opens in a new tab)

How to fix?

Upgrade Echo:latest gssproxy to version 0.8.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gssproxy package and not the gssproxy package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

gssproxy (aka gss-proxy) before 0.8.3 does not unlock cond_mutex before pthread exit in gp_worker_main() in gp_workers.c. NOTE: An upstream comment states "We are already on a shutdown path when running the code in question, so a DoS there doesn't make any sense, and there has been no additional information provided us (as upstream) to indicate why this would be a problem.

CVSS Base Scores

version 3.1