Allocation of Resources Without Limits or Throttling Affecting jq package, versions <1.5+dfsg-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.38% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-JQ-18610959
  • published11 Aug 2026
  • disclosed6 May 2016

Introduced: 6 May 2016

CVE-2016-4074  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade Echo:latest jq to version 1.5+dfsg-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jq package and not the jq package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The jv_dump_term function in jq 1.5 allows remote attackers to cause a denial of service (stack consumption and application crash) via a crafted JSON file. This issue has been fixed in jq 1.6_rc1-r0.

CVSS Base Scores

version 3.1