CVE-2026-54679 Affecting jq package, versions <1.6-2.1+deb12u2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-JQ-18610979
  • published11 Aug 2026
  • disclosed25 Jun 2026

Introduced: 25 Jun 2026

CVE-2026-54679  (opens in a new tab)

How to fix?

Upgrade Echo:latest jq to version 1.6-2.1+deb12u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jq package and not the jq package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun. This vulnerability is fixed in 1.8.2.

CVSS Base Scores

version 3.1