Improper Authentication Affecting lemonldap-ng package, versions <2.16.1+ds-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.96% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LEMONLDAPNG-18610992
  • published11 Aug 2026
  • disclosed31 Mar 2023

Introduced: 31 Mar 2023

CVE-2023-28862  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Echo:latest lemonldap-ng to version 2.16.1+ds-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lemonldap-ng package and not the lemonldap-ng package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in LemonLDAP::NG before 2.16.1. Weak session ID generation in the AuthBasic handler and incorrect failure handling during a password check allow attackers to bypass 2FA verification. Any plugin that tries to deny session creation after the store step does not deny an AuthBasic session.

CVSS Base Scores

version 3.1