Server-Side Request Forgery (SSRF) Affecting lemonldap-ng package, versions <2.16.1+ds-deb12u2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.75% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LEMONLDAPNG-18610993
  • published11 Aug 2026
  • disclosed29 Sept 2023

Introduced: 29 Sep 2023

CVE-2023-44469  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Echo:latest lemonldap-ng to version 2.16.1+ds-deb12u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lemonldap-ng package and not the lemonldap-ng package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A Server-Side Request Forgery issue in the OpenID Connect Issuer in LemonLDAP::NG before 2.17.1 allows authenticated remote attackers to send GET requests to arbitrary URLs through the request_uri authorization parameter. This is similar to CVE-2020-10770.

CVSS Base Scores

version 3.1