Information Exposure Affecting libgcrypt20 package, versions <1.6.0-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.53% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBGCRYPT20-19643754
  • published8 Sept 2026
  • disclosed10 Oct 2014

Introduced: 10 Oct 2014

CVE-2014-5270  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Echo:latest libgcrypt20 to version 1.6.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

CVSS Base Scores

version 3.1