Information Exposure Affecting libgcrypt20 package, versions <1.6.3-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.95% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBGCRYPT20-19643755
  • published8 Sept 2026
  • disclosed29 Nov 2019

Introduced: 29 Nov 2019

CVE-2015-0837  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

Upgrade Echo:latest libgcrypt20 to version 1.6.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."

CVSS Base Scores

version 3.1