Information Exposure Affecting libgcrypt20 package, versions <1.6.5-2


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBGCRYPT20-19643756
  • published8 Sept 2026
  • disclosed19 Apr 2016

Introduced: 19 Apr 2016

CVE-2015-7511  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Echo:latest libgcrypt20 to version 1.6.5-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Libgcrypt before 1.6.5 does not properly perform elliptic-point curve multiplication during decryption, which makes it easier for physically proximate attackers to extract ECDH keys by measuring electromagnetic emanations.

CVSS Base Scores

version 3.1