Information Exposure Affecting libgcrypt20 package, versions <1.7.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.6% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBGCRYPT20-19643757
  • published8 Sept 2026
  • disclosed13 Dec 2016

Introduced: 13 Dec 2016

CVE-2016-6313  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Echo:latest libgcrypt20 to version 1.7.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The mixing functions in the random number generator in Libgcrypt before 1.5.6, 1.6.x before 1.6.6, and 1.7.x before 1.7.3 and GnuPG before 1.4.21 make it easier for attackers to obtain the values of 160 bits by leveraging knowledge of the previous 4640 bits.