CVE-2011-1935 Affecting libpcap package, versions <1.1.1-4


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.65% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBPCAP-19637969
  • published6 Sept 2026
  • disclosed20 Oct 2017

Introduced: 20 Oct 2017

CVE-2011-1935  (opens in a new tab)

How to fix?

Upgrade Echo:latest libpcap to version 1.1.1-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap package and not the libpcap package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

pcap-linux.c in libpcap 1.1.1 before commit ea9432fabdf4b33cbc76d9437200e028f1c47c93 when snaplen is set may truncate packets, which might allow remote attackers to send arbitrary data while avoiding detection via crafted packets.

CVSS Base Scores

version 3.1