Improper Handling of Exceptional Conditions Affecting libsdl2-image package, versions <2.0.5+dfsg1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.97% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LIBSDL2IMAGE-19698211
  • published12 Sept 2026
  • disclosed3 Jul 2019

Introduced: 3 Jul 2019

CVE-2019-5051  (opens in a new tab)
CWE-755  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Echo:latest libsdl2-image to version 2.0.5+dfsg1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2-image package and not the libsdl2-image package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An exploitable heap-based buffer overflow vulnerability exists when loading a PCX file in SDL2_image, version 2.0.4. A missing error handler can lead to a buffer overflow and potential code execution. An attacker can provide a specially crafted image file to trigger this vulnerability.

CVSS Base Scores

version 3.1