Out-of-Bounds Affecting mapserver package, versions <5.2.2-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.01% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MAPSERVER-20044322
  • published22 Sept 2026
  • disclosed31 Mar 2009

Introduced: 31 Mar 2009

CVE-2009-0839  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Echo:latest mapserver to version 5.2.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

Stack-based buffer overflow in mapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2, when the server has a map with a long IMAGEPATH or NAME attribute, allows remote attackers to execute arbitrary code via a crafted id parameter in a query action.

CVSS Base Scores

version 3.1