Information Exposure Affecting mapserver package, versions <7.0.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.5% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MAPSERVER-20044339
  • published22 Sept 2026
  • disclosed8 Dec 2016

Introduced: 8 Dec 2016

CVE-2016-9839  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Echo:latest mapserver to version 7.0.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.

CVSS Base Scores

version 3.1