Heap-based Buffer Overflow Affecting mruby package, versions <3.0.0-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.63% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MRUBY-19698245
  • published12 Sept 2026
  • disclosed2 Jan 2022

Introduced: 2 Jan 2022

CVE-2022-0080  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Echo:latest mruby to version 3.0.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

mruby is vulnerable to Heap-based Buffer Overflow

CVSS Base Scores

version 3.1