Out-of-Bounds Affecting mruby package, versions <3.1.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.05% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MRUBY-19698265
  • published12 Sept 2026
  • disclosed14 Jan 2022

Introduced: 14 Jan 2022

CVE-2021-46020  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Echo:latest mruby to version 3.1.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An untrusted pointer dereference in mrb_vm_exec() of mruby v3.0.0 can lead to a segmentation fault or application crash.

CVSS Base Scores

version 3.1