Incorrect Permission Assignment for Critical Resource Affecting multipath-tools package, versions <0.4.8-15


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.49% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MULTIPATHTOOLS-19698264
  • published12 Sept 2026
  • disclosed30 Mar 2009

Introduced: 30 Mar 2009

CVE-2009-0115  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Echo:latest multipath-tools to version 0.4.8-15 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream multipath-tools package and not the multipath-tools package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

The Device Mapper multipathing driver (aka multipath-tools or device-mapper-multipath) 0.4.8, as used in SUSE openSUSE, SUSE Linux Enterprise Server (SLES), Fedora, and possibly other operating systems, uses world-writable permissions for the socket file (aka /var/run/multipathd.sock), which allows local users to send arbitrary commands to the multipath daemon.

CVSS Base Scores

version 3.1