Link Following Affecting multipath-tools package, versions <0.9.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.68% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MULTIPATHTOOLS-19698267
  • published12 Sept 2026
  • disclosed29 Oct 2022

Introduced: 29 Oct 2022

CVE-2022-41973  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Echo:latest multipath-tools to version 0.9.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream multipath-tools package and not the multipath-tools package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

multipath-tools 0.7.7 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited in conjunction with CVE-2022-41974. Local users able to access /dev/shm can change symlinks in multipathd due to incorrect symlink handling, which could lead to controlled file writes outside of the /dev/shm directory. This could be used indirectly for local privilege escalation to root.

CVSS Base Scores

version 3.1