Link Following Affecting nano package, versions <2.2.4-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.37% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-NANO-18234834
  • published23 Jul 2026
  • disclosed16 Apr 2010

Introduced: 16 Apr 2010

CVE-2010-1160  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Echo:latest nano to version 2.2.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nano package and not the nano package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

GNU nano before 2.2.4 does not verify whether a file has been changed before it is overwritten in a file-save operation, which allows local user-assisted attackers to overwrite arbitrary files via a symlink attack on an attacker-owned file that is being edited by the victim.

CVSS Base Scores

version 3.1