CVE-2019-11461 Affecting nautilus package, versions <3.30.5-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-NAUTILUS-21173116
  • published17 Oct 2026
  • disclosed22 Apr 2019

Introduced: 22 Apr 2019

CVE-2019-11461  (opens in a new tab)

How to fix?

Upgrade Echo:latest nautilus to version 3.30.5-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nautilus package and not the nautilus package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in GNOME Nautilus 3.30 prior to 3.30.6 and 3.32 prior to 3.32.1. A compromised thumbnailer may escape the bubblewrap sandbox used to confine thumbnailers by using the TIOCSTI ioctl to push characters into the input buffer of the thumbnailer's controlling terminal, allowing an attacker to escape the sandbox if the thumbnailer has a controlling terminal. This is due to improper filtering of the TIOCSTI ioctl on 64-bit systems, similar to CVE-2019-10063.