Arbitrary Argument Injection Affecting network-manager-l2tp package, versions <1.20.8-1+deb12u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-NETWORKMANAGERL2TP-19823648
  • published15 Sept 2026
  • disclosed23 Sept 2026

Introduced: 15 Sep 2026

CVE-2026-75131  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade Echo:latest network-manager-l2tp to version 1.20.8-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream network-manager-l2tp package and not the network-manager-l2tp package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

CVSS Base Scores

version 3.1