Out-of-bounds Write Affecting openjpeg2 package, versions <2.5.3-2.1~deb13u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.84% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-OPENJPEG2-21751295
  • published27 Oct 2026
  • disclosed3 Sept 2018

Introduced: 3 Sep 2018

CVE-2018-16376  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Echo:latest openjpeg2 to version 2.5.3-2.1~deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openjpeg2 package and not the openjpeg2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in OpenJPEG 2.3.0. A heap-based buffer overflow was discovered in the function t2_encode_packet in lib/openmj2/t2.c. The vulnerability causes an out-of-bounds write, which may lead to remote denial of service or possibly unspecified other impact.